This project is read-only.

Install Issue

Dec 20, 2013 at 4:18 PM
I am trying to install the on prem version of the solution. When I try to install the solution, I get an error. The error is: InnerException: Microsoft.Crm.CrmException: Unable to load plug-in assembly.
and it is on the isigmplugins. This is just a placeholder dll, right?

Any ideas?
Dec 20, 2013 at 5:22 PM

The ISI GM Plugin is optional. Can you send us a screen shot and the actual step in the installation guide that this is failing?

Dec 20, 2013 at 7:33 PM
Thanks for the quick response. I'll have to run the solution import again to see it. But, going through your installation guide:
  • first tried the org import method, using your DB backup. Restored the DB, and tried to import the org. Got a message that the your database was a different version from ours. Did not look into that any further, moved on to solution import.
  • tried to import the solution file.
And that's as far as I got.

Dec 20, 2013 at 8:12 PM

What version of Dynamics CRM On-Prem are you trying to install it on?

Dec 23, 2013 at 6:34 PM
2013 - to be exact.

I tried installing on a different vm, in case there was something funky about the environment we were trying to install on.

Same thing. First thing I did, after creating a new org, was to try and import the solution. Error is on the ISI.GM2013.Plugins solution. The error is pretty generic. Image

-<Row ss:AutoFitHeight="0" type="Plugin Assembly">-<Cell ss:StyleID="s137" name="Time"><Data ss:Type="String">13:26:49.56</Data></Cell>-<Cell ss:StyleID="s137" name="ItemType"><Data ss:Type="String">Plugin Assembly</Data></Cell>-<Cell ss:StyleID="s137" name="Id"><Data ss:Type="String">ISI.GM2013.Plugins, Version=, Culture=neutral, PublicKeyToken=643746afee44320d</Data></Cell>-<Cell ss:StyleID="s137" name="Name"><Data ss:Type="String">ISI.GM2013.Plugins</Data></Cell>-<Cell ss:StyleID="s137" name="LocalizedName"><Data ss:Type="String">ISI.GM2013.Plugins</Data></Cell>-<Cell ss:StyleID="s137" name="OriginalName"><Data ss:Type="String"/></Cell>-<Cell ss:StyleID="s137" name="Description"><Data ss:Type="String"/></Cell>-<Cell ss:StyleID="s137" name="Status"><Data ss:Type="String">Failure</Data></Cell>-<Cell ss:StyleID="s137" name="ErrorCode"><Data ss:Type="String">0x80044191</Data></Cell>-<Cell ss:StyleID="s137" name="ErrorText"><Data ss:Type="String">Unable to load plug-in assembly.</Data></Cell></Row>

I can send more info, screenshop, but where to?
Jan 9, 2014 at 2:15 PM
kenmal wrote:
What version of Dynamics CRM On-Prem are you trying to install it on?
Hi, I'm getting the exact same issue. CRM 2013 On-Prem. I tried to restore your provided db, but the system check (before kicking off the install) failed with the exact same message that Waxxconsulting got. The db was a different version than the installed version. I was thinking that maybe the db was from an earlier build of CRM 2013? Maybe the beta or RC?

Then I tried to install the solution file. Got the same exact error message. ISI.GM2013.Plugins Unable to load Plugin assembly.

Any ideas?
Jan 9, 2014 at 4:18 PM

I will try and reproduce the problem later today and let you next steps.


Jan 10, 2014 at 2:16 AM
Thanks. I tried downloading from the CRM App Store, but after all the hassel of installing the App Store Solution file, then trying to install your solution, it kept bombing on me. You should really get in touch with the MSFT PubSec folks, because this is not working at all.
Jan 22, 2014 at 3:18 AM
Hi All,

Any update on this discussion, I'm also facing same problem here.
2013 On-Prem
SQL Server 2012.

Mar 5, 2014 at 10:02 PM
I'm experiencing the same problem. Same environment as indikaparane.

2013 On-Prem
SQL Server 2013.
Mar 5, 2014 at 10:17 PM

I will test this out today and provide feedback shortly.

Mar 6, 2014 at 6:08 PM
Edited Mar 12, 2014 at 8:22 PM
Thanks, much appreciated :)

Hi Ken, Any chance you have any new information that might help get past this error? (I was able to install with the new Solution file (thanks again!), but it would be nice if I was also able to install using the .bak file and Import Organization (and have access to some pre-canned data). Thanks again.

2013 On-Prem (Rollup 1)
SQL Server 2012